All systems operational

Website issue

Resolved
Minor outage
Started over 1 year ago Lasted 19 minutes

Affected

Website
Services
Aternos
exaroton
Updates
  • Resolved
    Resolved

    The problem is resolved now and everything should be working as expected again.

  • Investigating
    Investigating

    We are currently investigating a problem with our website. Our website might be unavailable for you or you might get errors on our website.