All systems operational

Payment provider issue

Resolved
Partial outage
Started 4 months ago Lasted about 2 hours

Affected

Website
Services
exaroton
Updates
  • Resolved
    Resolved

    The problem is resolved now and everything should be working as expected again.

  • Investigating
    Investigating

    Our payment provider Paddle is currently experiencing issues that make it impossible for us to initiate any payments. We have contacted Paddle and hope that this issue will be resolved as soon as possible.